Welcome to the mailbox.org user forum!
 

Problems sending mail

3875787 shared this question 8 days ago
Answered

I've just made five trial accounts to test the functionality before paying and I'm having 2 problems already. First, I'm unable to send any attachments at all from the mailbox.org webmail (Error: "Wrong or missing login data to access mail transport server smtp.mailbox.org. Please check associated account's settings/credentials.") and second, I'm unable to send any mail at all, with or without attachments, from Thunderbird (Error: Failed due to unexpected error 80004005. No description is available. The message could not be sent using Outgoing server (SMTP) smtp.mailbox.org for an unknown reason. Please verify that your Outgoing server (SMTP) settings are correct and try again."). I'm using Windows 10, if that helps. I've seen other posts, a lot of them, saying that getting locked out of your account by spam filters is very common on mailbox.org, so if this is still a problem, could please let me know? Dependable email service is crucial in my line of work. Thank you! UPDATE: I'm finding I can't send mail, even without attachments, to even mailbox.org email addresses. So no sending mail at all.

Comments (2)

photo
1

Not sure why this is marked as answered when there is no answer here, but I still cannot send @mailbox.org mail to @mailbox.org addresses, even without attachments.. I just tried an account I've hardly used yet, so I'm sure I haven't exceeded any limits.

photo
1

Call me crazy, but I took a chance, but I took a chance and paid for one of my accounts, and it didn't make any difference. I still can't send mail. I'm gathering that while mailbox.org sounds like a good idea, sadly, it doesn't work very well.

photo
1

Have you opened a ticket at https://help.mailbox.org to check, if the anti-abuse system marked your registration as suspicious and blocked your account for sending e-mails?

photo