Welcome to the mailbox.org user forum!

Mailbox Encryption Not Working - Account Unsecure!!!

9773114 shared this problem 23 months ago


Few days ago I purchased Mailbox account with 1-year plan deal. Right from the start I noticed email encryption is not working. Inbox encryption tab, when I activate inbox encryption by loading my public key, I get the following error response from the server:

Please review your mail filter rules as they seem to be invalid. Response from server: "Open-Xchange: line 19: error: pgp_encrypt command: invalid ASCII armor for key 1/373410184: invalid tail line. Open-Xchange: line 55: error: pgp_encrypt command: invalid ASCII armor for key 1/373412664: premature end of header. Open-Xchange: error: validation failed. "

In addition, next to encrypted mailbox rule indicates that “This rule contains unsupported properties.

So, something within the system broke encryption functionalities, which is the most critical security feature of mailbox account. It appears that public key set is either expired or broken, so the inbox no longer being encrypted.

This is paid account. As such, I accept it to be fully functional and secure, as Advertised by Mailbox team. I asked mailbox support team to address this problem ASAP, but so far no response. Does anyone else experience same problem with inbox encryption functionality?

Thanks you!

Replies (4)


Yeah, I had the same problem for some time back then when I used PGP. Later, it somehow worked.

Keep in mind that this feature only protects the content of your messages if someone breaks into mailbox's servers or "guesses" your login.

If theres malware on your device, it doesn't protect either because then, your secret PGP keys are also leaked.

It's pretty useless for protecting your email content from mailbox admins, because they could just save an unencrypted copy before they encrypt the incoming email.


Its also Best Practice to regularly delete old emails and other data if you keep it online[1]. German minister of finance Olaf Scholz leads by example.

[1] see here e.g.: https://infosec-handbook.eu/blog/ecsm2019-cyber-hygiene/#your-accounts


Hi, I've had the same problem and solved it this way:

Check if expiration date of main key an all sub keys is OK. If the key is expired the encrypted inbox doesn't work anymore. This is to ensure that no old and potentially compromised keys are in use anymore. If this behavior is good or bad depends on your position and is at least questionable but no error.

Then remove the old key from the inbox encryption setting and uncheck "Activate PGP encryption for incoming e-mails".

Next go to "Filter Rules" and remove the/all "encrypted inbox"-rule(s).

If you now import the new/refreshed PGP-key it should work again.

Hope this helps...


I am experiencing a similar but different problem:
Please review your mail filter rules as they seem to be invalid. Response from server: "Open-Xchange: line 5: error: unknown command 'n' (only reported once at first occurrence). Open-Xchange: error: validation failed. "

My sieve rules were damaged somehow, many rules are gone including the default inbox encryption rule. I suspect it's just a matter of repairing the sieve file, for which I depend on the support team.


Support just confirmed that indeed my sieve file has been damaged (no idea how!) and that they will proceed with restoring the last working backup.

Leave a Comment
Attach a file