Welcome to the mailbox.org user forum!
 

Database Check Failure on "eM Client for OX App Suite" Startup

5018126 shared this problem 6 months ago
Published

Something caused my eM Client program to crash with an error, and now it will not re-start. Every time I try, it goes through the database check process and ultimately returns this error:



7e9b3b2ecf23ec702ea3031784cbda3b


The "Details" text is as follows:

  1. System.Data.SQLite.SQLiteException (0x80004005): disk I/O error
  2. disk I/O error
  3. at System.Data.SQLite.SQLite3.Prepare(SQLiteConnection cnn, String strSql, SQLiteStatement previous, UInt32 timeoutMS, String& strRemain)
  4. at System.Data.SQLite.SQLiteCommand.BuildNextCommand()
  5. at System.Data.SQLite.SQLiteCommand.GetStatement(Int32 index)
  6. at System.Data.SQLite.SQLiteDataReader.NextResult()
  7. at System.Data.SQLite.SQLiteDataReader..ctor(SQLiteCommand cmd, CommandBehavior behave)
  8. at System.Data.SQLite.SQLiteCommand.ExecuteReader(CommandBehavior behavior)
  9. at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery(CommandBehavior behavior)
  10. at System.Data.SQLite.SQLiteCommand.ExecuteNonQuery()
  11. at System.Data.SQLite.SQLiteConnection.Open()
  12. at MailClient.Storage.Data.DataStore.GetConnectionInternal(String relativeName)
  13. at DbRepair.CorruptionChecker.CheckCorruption(RepairOptions repairOptions, CancellationToken token)
  14. at DbRepair.CheckingProcess.Check(CancellationToken token)
  15. Data:
  16. SQLiteCommandText: PRAGMA synchronous=Normal
  17. databaseFile: 78f94150-be36-4b17-b7c7-f8c3f5b6fda5\1676086f-cf68-4b94-a3d0-8022465045c2\mail_index.dat



This also still happens after restarting the computer, so for now it seems like the program is 100% broken. Is there anything else I can try besides uninstalling/reinstalling?

Comments (2)

photo
1

Please have a look at the alert banner at https://mailbox.org and also read https://mailbox.org/en/maintenance/

photo
1

Hello, thank you for your reply.

This error has been received all day long today, and it is specifically with the eM application and not the webmail or SMTP interface. I have other email accounts set up with the eM application as well and I cannot run the application at all, so I don't believe it is specific to the mailbox.org downtime.

Thank you!