Welcome to the mailbox.org user forum!
 

Email stopped working on BlackBerry

2621480 shared this problem 3 weeks ago
Published

Email on my older BlackBerry Bold 9900 has been working perfectly until just recently when it stopped and asked me to verify the password for the email account - which I did - and it rejected it :|

I know its correct as I can log into the web portal and also via Widows Client.

I tried removing the email account from the BlackBerry and starting again adding an account but it does not accept the credentials.

This happened around the time of the recent changes at mailbox.org

Is there alternative server name I can try to imap.mailbox.org ? or any other things I can try?

Thanks!

Comments (5)

photo
1

Tested on other hosts with same results - must a be a BB issue. Please Close Ticket.

photo
1

Have now done a security wipe, resent the service books etc and I have 3 other ISP's working fine but not mailbox.org

Oddly the BlackBerry validation tool works fine http://www.blackberry.com/eavt2

But the handset does not and returns a short error message [Problem connecting to server] when trying to setup mailbox.org

Did anything change at mailbox.org about 2 weeks ago? Was working brilliantly for about a month.

photo
1

As an aside I managed to get LogicMail 3rd Party App working with mailbox.org - so the issue seems to be the validation process during setup from the native mail app via the Blackberry servers to mailbox.org

Any other older BlackBerry users out there had similar issue or resolved it?

photo
1

So I now have 3 other ISP's setup for email, namely UK2 / Plusnet and GMail

Interestingly when setting up GMail I got a security alert about a blocked attempt at login from South Africa on this IP Address: 178.239.83.1

http://whois.domaintools.com/178.239.83.1 says Canada - in any case I was wondering if mailbox.org are blocking for similar reasons as GMail i.e. looks suspicious?

photo
1

Is this just a community forum or do mailbox techs ever respond to questions?