Welcome to the mailbox.org user forum!
 

mailbox Guard - external user unable to decrypt with password

7386139 shared this problem 2 years ago
Published

I am evaluating mailbox.org service in comparison to others like Protonmail, Tutanota and Posteo.


I have been trying to use the Guard encryption function to send an encrypted email message to an external user - one of the other mail services as well as a Yahoo account and have been unable to decrypt the message using the Guard password.


The external user gets the message with link to the temporary mailbox and the instruction to Please provide your encryption password and I understood that they would just need to enter the Guard password that I created and shared with them. I opened the encrypted email as the mailbox user and tried the PGP inline, etc. but none of the external users can decrypt.


They get the Bad username/Password error message and are prompted to enter their username and password. If this is how it functions for external users this will be to complex a process for them. I used both Protonmail and Tutanota's encrypt function and it worked seamlessly for the external accounts, including for mailbox user.


I've looked at the knowledgebase, help sections but still can't do this basic function.

Comments (5)

photo
1

I've been using a test account and tested the "Encrypted message to non PGP users" by sending such a message to two different addresses.


Both accounts received the first message with the link, but neither received the second e-mail with the password.


This feauture was one of the things that won me over to mailbox.org and I would be very sad if this feature didn't work properly...

photo
1

The system doesn't send a second e-mail, because that would be stupid. Sending just TWO mails instead of ONE isn't really more safe.

IF you want to protect it by a PIN code (you don't have to do that, it's your choice of extra security) you have to send the PIN to the recipient by yourself, choosing something like SMS, lettre, phone call or whatever.

photo
1

Well, according to your own Knowledge Base, it does send the password in a second email, UN-ENCRYPTED. What is stupid is that you do not seem to know that!


https://userforum-en.mailbox.org/knowledge-base/article/my-recipient-does-not-use-pgp

photo
photo
1

yes, its broken here also no 2nd emails, what gives, the service should be removed if it is broken IMO, seems that support is also broken ....... guess I'll need to move to one of the others when my year is up , guess I should not have signed up for a year lol

photo
1

*edit* actually I was testing it by emailing my gmail (recovery email acct), so it wasn't showing me to create a pw, which is how it works, it doesn't send two emails, it's a link to a website where the receiver creates their own pw, what happens if they lose it, not sure , but it does work as of April 30, 2018 here