Welcome to the mailbox.org user forum!
 

Recover password with OTP

5141258 shared this problem 3 years ago
Published

A message appears each time I log into the account with OTP


It asks me to enter the previous password but seems that does not work.


"Failed to recover accounts. Password is invalid or there was a problem."


Can anyone tell me what I can do with this?


Thanks

Comments (10)

photo
1

Same problem for me !

In addition using OTP trigger a recover password windom each time

photo
1

Same problem for me.

photo
1

Same problem here too. Very annoying.

photo
1

Same problem with me!


It partial defeats the purpose of OTP. If i have to put my SMTP password on insecure computers then what's the purpose of OTP?

photo
1

Also having this issue. Honestly making me consider moving away from the service if it cannot reliably provide traditional Multi-Factor authentication.

photo
1

This is a full Muilti-Factor Authentication. In fact, we're not using the main password, weÄre using a seperate PIN which is much more secure.


The dialog "Failed to recover accounts. Password is invalid or there was a problem." is because access data to EXTERNAL mailaccount are encrypted with the password. Which is a good idea to protect them, but that's a bad idea if OTP is enabled.


However, last week we found some ideas on how to workaround that, we'll see during the next weeks.


And/But: This has NOTHING to do with the login into mailbox.org. That's ONLY about decrypting the password for external mailaccounts, twitter-logins or stuff like that.

photo
1

There must be a bug on your code

  1. The dialog "Failed to recover accounts. Password is invalid or there was a problem." is because access data to EXTERNAL mailaccount are encrypted with the password. Which is a good idea to protect them, but that's a bad idea if OTP is enabled.

Im only using mailbox. I dont use any other account but i still get the recover password windows that asks me for my smtp password.

If i press cancel it gets away and i can open my mailbox.

The problem besides being annoying made me really sceptical whether i should continue my subscription to you.

photo
1

Peer,


Thanks for the quick response and clarification on the issue. Removing the external mailbox I had added caused the prompt to disappear.


To recreate the issue:

  1. Add Gmail Account
  2. Enable OTP
  3. Prompt is received on each sign in, entering the Gmail password or mailbox.org service password do not resolve the issue


I suggest updating that error message to be more descriptive. As others have mentioned it was mildly alarming to enable OTP and then receive these prompts.

photo
1

I've recently have this same issue with my account, I didn't see this thread so I opened I new one describing my problem (here you have the link)


Here I describe how I reached the problem:

1. Wanted to link my Google account contacts with my mailbox contacts.

2. Added the connection with my Google account

3. Enable 2FA

4. Reset the password


At this point the message showed up for the first time, but I put my old password and It seemed to work.


5. Change the password again (I didn't like the one that was sent by email)


At this point the message started to appear each time that I login in the application.

Finally I reached this thread and Peer Heinlein gave me the answer:


The dialog "Failed to recover accounts. Password is invalid or there was a problem." is because access data to EXTERNAL mailaccount are encrypted with the password. Which is a good idea to protect them, but that's a bad idea if OTP is enabled.

So, what I've done is to delete my Google account connection, and the message has disappeared.

photo
1

We released an update today where we're now able to store the external credentials in a safe manner even when OTP is enabled.


You need maybe one more change of the credentials after your next login. -But after that the credentials are independet from your OTP password, so then the recover-window should be gone.