security key for custom domain

3200416 shared this question 2 years ago
Answered

Could you please explain where should I place the SecurityCode generated while adding an external domain alias.

When I was playing with other mail providers I had to specify MX and TXT values. Here I get one long string and could find any info where it should be placed.

So if I got a string like this:

    90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com. IN TXT 4cc6e0af122axxxxxxx3d0106699354bca7

should

    90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com

go as MX value and

    4cc6e0af122axxxxxxx3d0106699354bca7

as TXT value?

Comments (10)

photo
4

90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com is the Hostname.

Please define a TXT-Record with the value "4cc6e0af122axxxxxxx3d0106699354bca7" for the hostname 90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com.You have to create a new hostname "90f7460e1d1xxxxxxxe11f8ce048a64ba96" for this.

photo
1

Hi Peer,

Thanks for the explanation. I couldn't set it up earlier and I managed to do so after checking this post.

But I do have a problem as I still receive my emails at my Google Apps account (even after setting up the MX records to point it to Mailbox.org). Do I need to delete all my old MX and TXT records pointing to Google Apps?

photo
photo
1

Works! Great.

Thanks a lot!

Since I have a drag-n-drop style DNS record editor I couldnt't figure out what to do. The above solution made it clear.

Regards

photo
1

YOU ROCK!!!! THANX!!! :-)

photo
1

Hello, I have not figured out how to do this, even from this post. :( Is this they way it should look (from using these same examples)

CNAME

NAME: 90f7460e1d1xxxxxxxe11f8ce048a64ba96b

VALUE: 90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com

TXT

NAME: 90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com

VALUE: 4cc6e0af122axxxxxxx3d0106699354bca7

Or have I've done something wrong with my set-up? Because it does not seem to work for me.

photo
1

Hi,

Have the same problem.

I have use this config:

xxxxxxxxxxxxxxxxxxxxxxxxxxxx4c.domain.org 3600 IN TXT "6891xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxc12"

What did you mean by creting a new hostname with "xxxxxxxxxxxxxxxxxxxxxxxxxxxx4c"?

photo
1

I was in the same boat. I want to clarify that the last part of the explanation should be like this.


90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com is the Hostname.
Please define a TXT-Record with the value "4cc6e0af122axxxxxxx3d0106699354bca7" for the hostname 90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com. You have to create a new hostname "90f7460e1d1xxxxxxxe11f8ce048a64ba96" for this.


Once you set the host name remove the last part of your domain, by adding the sub domain provided by mailbox just add it as host and the value will be the key after TXT, most decent DNS providers will refresh the info in a few minutes, basically you don`t need to create a host you already doing it by adding the TXT record. You don`t need Cname or anything else.



See attachment for example using namecheap.com dns panel

Files: TXT.JPG
photo
1

Hi, same question but is not work for me. Also from naemcheap.

1º create a TXT Record with the info from mailbox.org:

HOST: XXXXXXXX.domain.com

VALUE: XXXXXXX

2º select custom MX at mail setting and wirte:

HOST: domain.com

VALUE: mxext1.mailbox.org. (with the dot)

PRIORITY: 10

i do the say for mxext2 and mxext3 but 20 for Priority for the last one

3º Create a TXT Record:

HOST: @

VALUE: v=spf1 include:mailbox.org

4º Erase all other default setting from namecheap (the 2 default Host Record entry)

All TTL are 1 min.

i check mx propagation from https://www.whatsmydns.net and not work, only the spf in TXT work.

Are you change the NAMESERVERS?

Any help?

Thx.

photo
1

I just finished setting this up my custom domain at namecheap. I attached an image that shows the settings.

Mailbox.org has detailed instructions here: https://userforum-en.mailbox.org/knowledge-base/article/e-mail-addresses-of-your-own-domain

First you set the security code: This was confusing to me at first. You need to create TXT record using the first string as a host, but you actually have to delete that address at the end of the string. So, in the example above, 90f7460e1d1xxxxxxxe11f8ce048a64ba96b.myadress.com is the first string. However, when you copy that string into the host field you need to delete the "myadress.com" part. So you just put 90f7460e1d1xxxxxxxe11f8ce048a64ba96b. in the host field. Then, in the same TXT record put 4cc6e0af122axxxxxxx3d0106699354bca7 as the value. You will get your own sets of numbers--don't use the ones from this example.

For the MX settings the instructions say

example.net. IN MX 10 mxext1.mailbox.org.

For namecheap, as shown, you create a Custom MX record, then the Type will say "MX record". After that, put @ as the host. Value is

mxext1.mailbox.org.

Then 10 is in the next field.

The instructions for the SRV field say this to use these values:

_autodiscover._tcp IN SRV 0 0 443 mailbox.org.For the SRV settings, in my case the first value is _autodiscover, and the second is _tcp, then 0, 0, 443, mailbox.org.

I hope this helps somebody. Of course the settings might be different at another domain host.

photo
1

Thx. you soo much, is work for me!

photo