Welcome to the mailbox.org user forum!
 

Using aliases - trial account

4057860 shared this idea 2 years ago
Completed

I'm testing out mailbox to see if it will meet my requirements so I have a trial account for 30 days. I have created the one alias I'm allowed however I do not appear to be able to send as that alias. I see that there should be a drop down upper left to select this (based on the FAQs) however only my mail identity is there.

Am I missing something or is it an issue with the trial accounts (makes it hard to test an alias out if that is the case!).

TIA

Nigel

Comments (6)

photo
1

Have you logged out and logged in again?

photo
1

Thanks Peter - yes I have (several times) and I created the alias yesterday but there is still no sign of the ability to use it to send mail - I only get my default ID. I'd like to use mailbox but if I can't use the aliases it's not for me sadly. I don't think I'm doing anything wrong.

Best Nigel

photo
1

Please contact support-en@mailbox.org. This is something our help desk team has to check individually.

photo
1

Thanks Peter - mail sent to them. Regards

photo
photo
1

I do realise that support may be busy however it took a week for me to get an answer and they asked for a screenshot which I sent immediately and I've heard nothing for a week now. Sadly I think my trial will expire before I ever get a chance to test it properly. I think that is a pity.

photo
1

Aaaah - got there with a helpful reply from support. However I had to login as the alias before it was available for use which maybe seems odd to me.

However it actually works very well I think - I'll try it some more tomorrow and hopefully sign up before the end of the week.

Thanks

photo