Welcome to the mailbox.org user forum!
 

With DKIM TXT records I get 10/10 with mailtester, with cname only 8.7 how is this possible?

8065235 shared this question 9 months ago
Answered

Hello,

Just joined mailbox.org today with a domain from cloudflare. I did a test with mailtester.com I get 10/10 with TXT dkim records, but with CNAME dkim records I'll get 8.7 I enclose my cloudflare settings. Can anybody help me out with this?

I appreciate your help.

Regards,

Marcel

Replies (1)

photo
2

What their report say about dkim?

maybe they don't like ed25519 key from mbo0003 and mbo0004?

photo
1

I cannot check it today already tested it 3 times. mbo0001 and 0002 are the same as the DNS TXT records. So maybe that's a problem for mail-tester I don't know. I find it kinda strange, with only the 2 txt records I'll get 10/10 but because mailbox advised to use CNAME DKIM I put those in cloudflare.

photo
1

Is it ok to remove mbo0003 and 0004 without problems or should I keep them?

photo
1

@TeCer This is my mail-checker test. Hopefully you can do something with this.

photo
1

I don't see problems on those results, the only "problem" is with the domain that has been registered for less than 7 days but you can't do anything about it.

Regarding mailtester.com results i think there is something about dkim keys, mbo0001 and mbo0002 use rsa key while mbo0003 and mbo0004 use new ed25519 key which, as far as i read on other forums, is not fully supported or compatible. But i'm not an expert of these things, you can open a ticket at support for clarification.

Anyway i have same dkim configuration and have no problems.

photo
1

Hey,

Thanks for your reply, can you run the same test on mail-tester.com to check the results with mine?

photo
1

Btw already contacted support yesterday but not yet a respons.

photo
1

@TeCer Hey again, Well I tested again with the 2 txt dkim records and now I have the same score as with the four cname records, it looks like mail-checker only looks at the first dkim record and it is verified. I think the low score is from my new domain only not from the dkim. So I think I just have to wait when my domain will mature. Maybe it was a hick up with mail-checker when I first tested it maybe he didn't see it was a new domain at the first time.

photo
1

ok, if mailtester.com does a simple dkim check of the email you send to it (like mail-tester.com) the score problem is related to the domain registered a few days ago.

I thought it did a dkim lookup of your domain and for some reason it didn't like mbo0003 and mbo0004 which use a different key than the first two.

try again in the next weeks and you should be fine.

photo
1

Thanks for your reply, also in touch with tech support right now. They send me another test to do. I will check it in the next few weeks!

With regards,

Marcel

photo
1

Well everything is solved now.

photo
Leave a Comment
 
Attach a file